I have a layered application with namespaces:
App.Core
- business layer logic servicesApp.Data
- data access layer store classes and data access objectsApp.Web
- user interface layer
I also have business objects/DTOs. They reside in App.Objects
namespace, but I dont like this naming convention. Why? Because this namespace will also have subnamespaces suffixed Objects like App.Objects.KeywordObjects
. These subnamespaces can't be without the Objects suffix, because some of them will also contain classes with the same name (App.Objects.KeywordObjects
will contain Keyword
and Keywords
classes).
I was thinking of changing App.Objects
to something else. So I don't have duplicate "Objects" word. But I can't seem to find any usable word. And I don't want to use acronyms like DTO or BO.
How do you normally name your namespaces and what would you suggest I should use in this case.