What is the Framework Design Guideline for naming boolean properties? If there isn't one, then what's your recommendation?
Let's say I have a User
class, and I need a property that specifies if the user is enabled or not. These are the options I can think of:
- Enable
- Enabled
- IsEnabled
- Disable
- Disabled
- IsDisabled
Also, if the BL says that the user must be disabled by default and explicitly enabled, should I prefer an 'enable' variation, considering that the default value for System.Boolean
is false
?