tags:

views:

329

answers:

7

I'm iterating over a vector and need the index the iterator is currently pointing at. AFAIK this can be done in two ways:

  • it - vec.begin()
  • std::distance(vec.begin(), it)

Which one is better or preferred and why?

A: 

I like this one: it - vec.begin(), because to me it clearly says "distance from beginning". With iterators we're used to thinking in terms of arithmetic, so the - sign is the clearest indicator here.

Eli Bendersky
It's more clear to use subtraction to find the distance than to use, quite literally, the word `distance` ?
Travis Gockel
@Travis, to me it is. It's a matter of taste and custom. We say `it++` and not something like `std::increment(it)`, don't we? Wouldn't that also count as less clear?
Eli Bendersky
The `++` operator is defined as part of the STL sequences as how we increment the iterator. `std::distance` calculates the number of elements between the first and last element. The fact that the `-` operator works is merely a coincidence.
Travis Gockel
@Eli: it's called `std::advance`
MSalters
@MSalters: and yet, we use ++ :-)
Eli Bendersky
+9  A: 

I would prefer std::distance(vec.begin(), it) as it will allow me to change the container without any code changes. For example, if you decide to use std::list instead of std::vector which doesn't provide a random access iterator your code will still compile. Since std::distance picks up the optimal method depending on iterator traits you'll not have any performance degradation either.

Naveen
When you're using a container without random access iterators, it's best *not to* compute such distances because it's inefficient
Eli Bendersky
@Eli: I agree with that, but in a very special case if it is really required, then still that code will work.
Naveen
I think the code should be changed anyway if the container changes - having a std::list variable named `vec` is bad news. If the code were re-written to be generic, taking the container type as a template parameter, that's when we can (and should) talk about handling non-random-access iterators ;-)
Steve Jessop
And specialisation for certain containers.
ScaryAardvark
A: 

According to http://www.cplusplus.com/reference/std/iterator/distance/, since vec.begin() is a random access iterator, the distance method uses the - operator.

So the answer is, from a performance point of view, it is the same, but maybe using distance() is easier to understand if anybody would have to read and understand your code.

Stéphane
+23  A: 

I would prefer it - vec.begin() precisely for the opposite reason given by Naveen: so it wouldn't compile if you change the vector into a list. If you do this during every iteration, you could easily end up turning an O(n) algorithm into an O(n^2) algorithm.

Another option, if you don't jump around in the container during iteration, would be to keep the index as a second loop counter.

UncleBens
Agreed. I'd say that the minus sign is best, but it would be better to keep a second loop counter than to use std::distance, precisely because this function could be slow.
Steven Sudit
+5  A: 

As UncleBens and Naveen have shown, there are good reasons for both. Which one is "better" depends on what behavior you want: Do you want to guarantee constant-time behavior, or do you want it to fall back to linear time when necessary?

it - vec.begin() takes constant time, but the operator - is only defined on random access iterators, so the code won't compile at all with list iterators, for example.

std::distance(vec.begin(), it) works for all iterator types, but will only be a constant-time operation if used on random access iterators.

Neither one is "better". Use the one that does what you need.

jalf
I've fallen foul of this in the past. Using std::distance on two std::map iterators and expecting it to be O(N).
ScaryAardvark
@ScaryAardvark: Don't you mean expecting it to be O(1)?
jalf
:) Yes. that's what I meant
ScaryAardvark
A: 

I'd use the - variant for std::vector only - it's pretty clear what is meant, and the simplicity of the operation (which isn't more than a pointer subtraction) is expressed by the syntax (distance, on the other side, sounds like pythagoras on the first reading, doesn't it?). As UncleBen points out, - also acts as a static assertion in case vector is accidentially changed to list.

Also I think it is much more common - have no numbers to prove it, though. Master argument: it - vec.begin() is shorter in source code - less typing work, less space consumed. As it's clear that the right answer to your question boils down to be a matter of taste, this can also be a valid argument.

Alexander Gessler
A: 

If you are already restricted/hardcoded your algorithm to using a std::vector::iterator and std::vector::iterator only, it doesn't really matter which method you will end up using. Your algorithm is already concretized beyond the point where choosing one of the other can make any difference. They both do exactly the same thing. It is just a matter of personal preference. I would personally use explicit subtraction.

If, on the other hand, you want to retain a higher degree of generality in your algorithm, namely, to allow the possibility that some day in the future it might be applied to some other iterator type, then the best method depends on your intent. It depends on how restrictive you want to be with regard to the iterator type that can be used here.

  • If you use the explicit subtraction, your algorithm will be restricted to a rather narrow class of iterators: random-access iterators. (This is what you get now from std::vector)

  • If you use distance, your algorithm will support a much wider class of iterators: input iterators.

Of course, calculating distance for non-random-access iterators is in general case an inefficient operation (while, again, for random-access ones it is as efficient as subtraction). It is up to you to decide whether your algorithm makes sense for non-random-access iterators, efficiency-wise. It the resultant loss in efficiency is devastating to the point of making your algorithm completely useless, then you should better stick to subtraction, thus prohibiting the inefficient uses and forcing the user to seek alternative solutions for other iterator types. If the efficiency with non-random-access iterators is still in usable range, then you should use distance and document the fact that the algorithm works better with random-access iterators.

AndreyT