views:

88

answers:

5

I'm writing an HTML form generation library. There's a top-level Form class, and at the bottom there are classes for each type of HTML form input object (Select, Textfield, Radio, etc.). There's a class in between, that holds groupings of 1 or more semantically related input objects.

For example, one type of this class could be called 'Login', and would contain a Textfield input and a Password input. As another example, the primary usage of the form library will be to generate online surveys, so the intermediate classes will be survey questions of various sorts.

My question is what to generically call these intermediate level classes. Some of the things that have been suggested within our working group are 'Set', 'Fieldset', 'Group', 'Block', 'Chunk', and 'Conglomeration'.

Several of these suggestions are "okay", but none of them have tripped the "that's it!" interrupt. (The one that came closest is the latter, but that's (a) far too long and (b) too subject to mispeling.) Does anyone have any better suggestions?

A: 

Component, as in the "Login Component" or the "Multivalued Response Component".

FYI. I find http://thesaurus.reference.com very helpful for problems like this.

tvanfosson
A: 

just call it a Foo or SematicallyRelatedInputs1 and start coding. a reasonable name should occur to you fairly soon. don't feel bad if you change the name a few times.

Ray Tayek
A: 

'FormBlob' perhaps?

'GroupedInput'?

If single word terms fail, fall back onto multitermed mashups =)

Wobin
A: 

TagSet might work. If i understand you correctly you'd used combinations of both things like:

<input type="text" /> <input type="password"/>

and

non-form elements like:

<dl>
  <dt>Question</dt>
  <dd>Answer<dd>
</dl>

or

The's are all collections of HTML tags. TagSet seems like a simple descriptive name.

Dave K
A: 

After further discussion within our working group, we ended up going with 'fieldset'.

Thanks for all the suggestions.

genehack