I am running a Tomcat application, and I need to display some time values. Unfortunately, the time is coming up an hour off. I looked into it and discovered that my default TimeZone is being set to:


Rather than the Pacific time zone. This is further indicated when I try to print the default time zone's display name, and it comes up "GMT-08:00", which seems to indicate to me that it is not correctly set to the US Pacific time zone. I am running on Ubuntu Hardy Heron, upgraded from Gutsy Gibbon.

Is there a configuration file I can update to tell the JRE to use Pacific with all the associated daylight savings time information? The time on my machine shows correctly, so it doesn't seem to be an OS-wide misconfiguration.


Hmm... off by one hour. DST possibly?

Is the date set correctly? What version of the JDK is this running on? ("java -version")

Mark Renouf

I am using 1.5, and it is most definitely a DST problem. As you can see, the time zone is set to not use daylight savings. My belief is it is generically set to -8 offset rather than the specific Pacific timezone. Since the generic -8 offset has no daylight savings info, it's of course not using it, but the question is, where do I tell Java to use Pacific time zone when it starts up? I'm NOT looking for a programmatic solution, it should be a configuration solution.

Mike Stone
+1  A: 

Ok, here's an update. A coworker suggested I update JAVA_OPTS in my /etc/profile to include "-Duser.timezone=US/Pacific", which worked (I also saw CATALINA_OPTS, which I updated as well). Actually, I just exported the change into the variables rather than use the new /etc/profile (a reboot later will pick up the changes and I will be golden).

However, I still think there is a better solution... there should be a configuration for Java somewhere that says what timezone it is using, or how it is grabbing the timezone. If someone knows such a setting, that would be awesome, but for now this is a decent workaround.

Mike Stone
+5  A: 

It's a "quirk" in the way the JVM looks up the zoneinfo file. See Bug ID 6456628.

The easiest workaround is to make /etc/localtime a symlink to the correct zoneinfo file. For Pacific time, the following commands should work:

# sudo cp /etc/localtime /etc/localtime.dist
# sudo ln -fs /usr/share/zoneinfo/America/Los_Angeles /etc/localtime

I haven't had any problems with the symlink approach.

Edit: Added "sudo" to the commands.

Jason Day
+1: I just ran into this on a fully updated Ubuntu 9.10 server. Sun JDK 1.6.0_15-b03, System is configured at installation time for US/Eastern timezone. /etc/localtime contains the identical contents of /usr/share/zoneinfo/US/Eastern. Java produces incorrect results for dates between March 15, 2010 and April 25. After replacing the file with a symlink to /usr/share/zoneinfo/US/Eastern, I now get correct results.I am astounded this bug is a) still open, b) affects a fully updated Ubuntu server (9.10 - Karmic).
Mark Renouf

It may help to double-check the timezone rules your OS is using.

/usr/bin/zdump -v /etc/localtime | less

This file should contain your daylight savings rules, like this one for the year 2080:

/etc/localtime  Sun Mar 31 01:00:00 2080 UTC = Sun Mar 31 02:00:00 2080 BST isdst=1 gmtoff=3600

You can compare this with the timezone rules you think you should be using. They can be found in /usr/share/zoneinfo/.


Thanks for the further responses!

I did a zdump of localtime and Los_Angeles... they were the same, however the symlink still worked!

Mike Stone
+1  A: 

I had a similar issue, possibly the same one. However my tomcat server runs on a windows box so the symlink solution will not work.

I set "-Duser.timezone=Australia/Sydney" in the JAVA_OPTS however tomcat would not recognize that DST was in effect. As a workaround i changed Australia/Sydney (+10 GMT) to Pacific/Numea (+11 GMT) so that times would correctly display however i would love to know the actual solution or bug, if any.


On Ubuntu, it's not enough to just change the /etc/localtime file. It seems to read /etc/timezone file, too. It's better follow the instruction to set the time zone properly. In particular, do the following:

$ sudo cp /etc/timezone /etc/timezone.dist
$ echo "Australia/Adelaide" | sudo tee /etc/timezone
$ sudo dpkg-reconfigure --frontend noninteractive tzdata

Current default time zone: 'Australia/Adelaide'
Local time is now:      Sat May  8 21:19:24 CST 2010.
Universal Time is now:  Sat May  8 11:49:24 UTC 2010.

On my Ubuntu, if /etc/localtime and /etc/timezone are inconsistent, Java seems to read default time zone from /etc/timezone .

Liu Zehua