The naming convention for event handlers of controls have always been controlName_EventName
, so basically, it reuses your own naming convention for the control, and then tucks on the name of the event.
This might be contrary to the general naming standard, but it has always been this way.
The upshot of this, is that tools like GhostDoc can recognize this format, and thus generate documentation that, while still generic, is more to the point, than if it were to try to deduce the purpose of the method by itself.
For instance, the "controlName_EventName" method could be documented like this:
/// <summary>
/// Handles the EventName event of the controlName control.
/// </summary>
/// <param name="sender">The source of the event.</param>
/// <param name="e">The <see cref="System.EventArgs"/> instance
/// containing the event data.</param>
protected void controlName_EventName(object sender, EventArgs e)
{
instead of more like this (since GhostDoc handles the above, I'm ad libbing here based on experience with bad method names):
/// <summary>
/// Control names the event name.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The e.</param>
protected void controlName_EventName(object sender, EventArgs e)
{