I'm running Server 2008 64bit with Hyper-V. I've created a virtual machine with Vista 64bit and installed it. I can't get the Vista virtual machine to see the network adapter.

I've set-up an external network on the Virtual Network Manager (Hyper-V) and associated that with the virtual machine (Vista). I've also tried using a Legacy Network Adapter but that didn't work either although that time the Vista machine saw the network card but couldn't connect through it.

This is (obviously) the first time I've tried to set-up a virtual machine.

Any ideas?

EDIT: I notice that this question has been voted down a couple of times. I know that it's not a programming question but I'm a developer setting up a virtual machine to test my C#/ASP.NET code on and thought that other developers may hit this problem as well when they're doing this...

+1  A: 

I don't know Hyper-V, but I know in VMWare you can create a network connection in Bridged mode (meaning the VM will get it's own IP address via DHCP if that's enabled) or host-only mode (meaning the VM can only communicate with the host). When Vista could see the card, could it communicate with the host machine (which would indicate a host-only connection was specified)? What kind of IP address did it have (I would guess Hyper-V has a built-in DHCP server like VMWare does?) -- that might give additional clues.

Sorry I don't know Hyper-V better...

+1  A: 

Make sure you have the Hyper-V Tools installed on the Guest VM. You shouldn't need the legacy adapter.

You also may want to make sure you have all of the latest updates which may have addressed your issue. Particularly, KB950050

+1  A: 

It turns out that Vista x64 running as a VM through Hyper-V doesn't support the virtual network connection/card and that you have to set it up as a legacy network card. When I eventually got the config settings correct for the legacy network and disable the virtual network it connected.

Thanks for the help guys - much appreciated!

Good to know. Starting to mess with Hyper-V in my office i'll keep that in mind.