I'm adding a boolean property to a class to indicate whether something is able to be closed. Searching around I see precedent for using "closeable" and "closable" to name such properties. Which is preferable and why?
also this: http://google.com/search?q=closeable
yjerem
2009-10-22 01:27:25
A:
I would create an interface called Closeable with one method called close().
Then you can implement it on the class any way your little heart likes. All the calling code is just going to call close.
Shaun F
2009-10-22 01:25:06
+2
A:
Oxford Dictionary has a definition for "Closable" but not "Closeable" Closable: http://www.askoxford.com/results/?view=searchresults&freesearch=closable&branch=&textsearchtype=exact
...So I'd say go with "Closable".
FrustratedWithFormsDesigner
2009-10-22 03:02:23