How do you think, is it a good idea to have such an enum:
enum AvailableSpace {
Percent10,
Percent20,
SqF500,
SqF600
}
The question is about the semantics of the values names, i.e. both percentage and square feet. I really believe that it's not a good idea, but I could not find and guidelines, etc. in support of this.
EDIT: This will be used to determine a state of an entity - i.e. as a read only property to describe a state of an object. If we know the total space (i.e. the object itself knows it), we have the option to convert internally, so we either have only percentage, or square feet, or both. The argument is, that "both" is not a good idea.
The above is an example of course, but the real problem is that some data providers send us totals (sq.f.), and others percentage, and my goal is to unify the UI. I'm free to make some approximations, so the exact values will be adapted based on how accurate we want to present the information.
The question is only about the semantics of the value names, not the content - i.e. if it is a good idea to put percentage in an (potential) int enum.