views:

720

answers:

11

Hello, I am having trouble figuring out how to break out of a loop that contains a switch statement. Break breaks out of the switch, not the loop.

There is probably a more elegant solution to this. I have implemented a flag that starts out as true and gets set to false and ends the loop. Can you offer a better solution?

Background: this code is used in a bar code workflow system. We have PocketPCs that have bar code scanners built in. This code is used in one of those functions. It prompts the user for different pieces of data throughout the routine. This piece allows them to scroll through some inventory records displaying that info on the PocketPC terminal (paged results) and allows them to enter "D" for Done, "Q" to quit.

Here is the current C# example that needs to be improved:

do
{
    switch (MLTWatcherTCPIP.Get().ToUpper())
    {
        case "": //scroll/display next inventory location
            MLTWatcherTCPIP.TerminalPrompt.ScrollBodyTextDown();
            break;
        case "P": //scroll/display previous inventory location
            MLTWatcherTCPIP.TerminalPrompt.ScrollBodyTextDown();
            break;
        case "D": //DONE (exit out of this Do Loop)
            // break; // this breaks out of the switch, not the loop
            // return; // this exists entire method; not what I'm after
            keepOnLooping = false;
            break;
        case "Q": //QUIT (exit out to main menu)
            return;
        default:
            break;
    }
} while (keepOnLooping);

Here is an example of code that does this in VB.NET

Do
    Select Case MLTWatcherTCPIP.Get().ToUpper
        Case "" ''#scroll/display next inventory location
            MLTWatcherTCPIP.TerminalPrompt.ScrollBodyTextDown()
        Case "P" ''#scroll/display previous inventory location
            MLTWatcherTCPIP.TerminalPrompt.ScrollBodyTextUp()
        Case "D" ''#DONE (exit out of this Do Loop)
            Exit Do
        Case "Q" ''#QUIT (exit out to main menu)
            Return
    End Select
Loop

Thanks,

Josh Blair

+6  A: 

You must use a goto statement for multi level breaks. It appears to be the only 'clean' way in C#. Using a flag is also useful, but requires extra code if the loop has other predicaments for running.

http://msdn.microsoft.com/en-us/library/aa664756(VS.71).aspx

It may be interesting to note that some other non-c languages have multi level breaks by doing break levels; (Java is just as useless, though, as it uses a goto disguised as a continue.. :P)

Tor Valamo
+1  A: 

A flag is the standard way to do this. The only other way I know of is to use a goto.

John Knoeller
+8  A: 

I'd try to avoid it, but you could use...

goto

However, angry mobs with pitchforks become an occupational hazard if you choose to do so.

Kevin Montrose
I gave you +1 by clicking with my pitchfork. (Reluctantly)
David Stratton
... or velociraptors...
Joel Coehoorn
http://xkcd.com/292/
Zano
+10  A: 

The only other way I know of is the dreaded goto. MSDN also says this.

However, I see no reason why you'd use it in this case. The way you have implemented works fine, and is more maintainable than a goto. I would keep what you have.

McAden
While `goto` may be dreaded, there are a small number of cases where it is actually useful and I believe this is one of them.
Steve Guidi
+1  A: 

imo this seems a perfectly fine way of breaking out of a while loop. It does what you expect with no side effects. I could think of doing

if(!keepOnLooping)
  break;

but that's not really any different in terms of execution.

Fry
+13  A: 

One option here is to refactor this loop into a method ("extract method"), and use return.

Marc Gravell
+1  A: 

Wrap it into a function and use a return statement to exit. How about that?

Hamish Grubijan
A: 

You could change the switch statement to a for/foreach loop. Once the condition is met set "keepOnLooping" to false and then use break to get out of the loop. The rest should take care of itself.

Chuck Conway
+3  A: 

Why not wrap the switch into a method that returns a boolean to keep on looping? It would have the side benefit of making the code more readable. There's a reason someone wrote a paper saying we don't need goto statements after all ;)

do
{
    bool keepOnLooping = TryToKeepLooping();
} while (keepOnLooping);

private bool TryToKeepLooping()
{
    switch (MLTWatcherTCPIP.Get().ToUpper())
    {
        case "": //scroll/display next inventory location
            MLTWatcherTCPIP.TerminalPrompt.ScrollBodyTextDown();
            break;
        case "P": //scroll/display previous inventory location
            MLTWatcherTCPIP.TerminalPrompt.ScrollBodyTextDown();
            break;
        case "D": //DONE (exit out of this Do Loop)
            // break; // this breaks out of the switch, not the loop
            // return; // this exists entire method; not what I'm after
            return false;
        case "Q": //QUIT (exit out to main menu)
            return true;
        default:
            break;
    }

    return true;
}
Jeffrey Cameron
A: 

You can replace the switch statement with an if/else statement. No goto needed and the break statement leaves the loop:

do
{
  String c = MLTWatcherTCPIP.Get().ToUpper();

  if (c = "")
    MLTWatcherTCPIP.TerminalPrompt.ScrollBodyTextDown();
  else if (c = "P")
    MLTWatcherTCPIP.TerminalPrompt.ScrollBodyTextUp();
  else if (c = "D")
     break;
  else if (c = "Q")
    return;
  else
  {
    // Handle bad input here.
  }
} while (keepLooping)
Chris R. Timmons
While this is fine for most applications, there is an important difference between `switch` and `if/else` being that the compiler can usually optimize the "branching" operations by using a jump table, resulting in faster code.
Steve Guidi
Steve, the code here is waiting for user input. It's already sat there for billions of nanoseconds doing absolutely nothing. Whether it takes one or one hundred nanoseconds to work out what the character typed was seems completely irrelevant. Optimizations should be driven by empirical data about real world user concerns, not by armchair guesses about what the compiler might do.
Eric Lippert
+2  A: 

I find this form to be ever-so-slightly more readable:

bool done = false;
while (!done) 
{ 
    switch (MLTWatcherTCPIP.Get().ToUpper()) 
    { 
        case "": //scroll/display next inventory location 
            MLTWatcherTCPIP.TerminalPrompt.ScrollBodyTextDown(); 
            break; 
        case "P": //scroll/display previous inventory location 
            MLTWatcherTCPIP.TerminalPrompt.ScrollBodyTextDown(); 
            break; 
        case "D": //DONE (exit out of this Do Loop) 
            done = true;
            break; 
        case "Q": //QUIT (exit out to main menu) 
            return; 
        default: 
            break; 
    } 
}
Jeffrey L Whitledge