I am looking for a nicer way of accomplishing the following code block which is part of an EmailAddress class/object. To my thinking, the parts array is clunky and I'm wondering if there isn't a one liner using tuples or Linq that would tidy it up a bit.
Also, what would be a better property name than "Alias" for the first part of the email address?
public string Alias { get; private set; }
public string Domain { get; private set; }
private void Split(string emailAddress)
{
var parts = emailAddress.Split(new[] { '@' });
Alias = parts[0];
Domain = parts[1];
}