I am looking for a (simple) text editor that can handle text in different encodings in the same document.

I need to develop some sites with mixed Japanese and English text and the editors I have now (on an English Windows system) are unable to display the Japanese text. Jedit files don't display the Japanese text I have inputted but when I look at the file in a browser it shows up correctly. Gvim shows all Japanese text in the editor as question marks and also in the browser. In Gvim inputting the kanji works (you input the pronounciation and then press space bar to get the kanji) but when you confirm the kanji you want it replaces that kanji with question marks. (1 question mark for every kanji).

Can someone recommend me a text editor to edit html and php files that is able to display utf-8 encoded text and also save as an utf-8 file ?

thank you.

After reading about emacs I installed it. see below.

Thanks everybody for the hints. if you don't have a unicode font yet you have to find one online or buy one. here are the instructions to install the font on a windows system

jEdit I changed my font in Jedit to a UTF font and now the Japanese shows up normally. inputting the Japanese is still problematic as you don't see what you are typing. (to change your font to edit files go to Utilities -> Global Options -> text area select a Unicode font and you'll be able to see the Japanese characters.

gVim I am still trying to figure out how to add a font in gvim. Once I know how to do that I ll update this.

Emacs Emacs does not show the kanji correctly, they are displayed as ??? but at least I can see what I type in Japanese and select the right word.

so at this point I have to say that in jEdit I can see Japanese text but I can't input Japanese text. Gvim I can input Japanese text but inside the text area it is displayed as ??? and the same goes for Emacs. adding a font in emacs and gvim is sadly enough not a trivial task. At the moment I use notepad with the Arial unicode MS font and saving as UTF-8 file as my Japanese editor. Not ideal but at least it works.

+5  A: 

Emacs correctly handles UTF-8 for me. (And of course, it can edit HTML and PHP files).

+2  A: 

It sounds like maybe the problem with Jedit is the font - are you using a font that can display all the characters correctly?

To be more precise, Arial Unicode MS is a reasonable choice for a Unicode font that can display a wide range of characters across the range of languages. There are certain issues with it that can make it less than optimal for some languages used in isolation - this is why there are also language specific Unicode fonts included with Windows.

+2  A: 

You can use just Notepad.exe with the "Arial Unicode MS" font (if all of your text is left-to-right, given the English windows version). Just Save as, select UTF-8.

In general, use your favourite editor with a font like "Arial Unicode MS". I mention this one because is the font with the greatest Unicode coverage I have seen,

+3  A: 

I would recommend Vim still. The problem you were seeing with questions marks is probably an issue with the font you were using. When displaying text that contains characters not in the currently language applications typically display them as empty boxes or question marks. See here for UTF-8 support in Vim.

This section of the Vim manual is also helpful, especially for setting up UTF-8 in Windows.

Mark A. Nicolosi
On windows, if you get question marks it means that the character encoding has been corrupted - for example you are trying to display UTF-8 as regular ANSI - if it is a problem with the font you will get boxes
����� <- Those are from They display as question marks on my system. Looking at it in context (looks random) it appears they are characters my system can't display
Mark A. Nicolosi
I'm pretty surer that means they have been corrupted somewhere along the line - given the source it could have been the blog software or the newsgroup scraper. See here: - the "wheel" symbol shows up as a box (for me)
Here is another bunch of boxes
Hmmm. You could be right, if you find a source put it here, though. I would post this as a question, but I'm not sure if its programming related enough...
Mark A. Nicolosi
Based on the OP's question, it sounds like they display as question marks when they are being typed into GVim. I wouldn't think a stable editor would corrupt the character encoding...
Mark A. Nicolosi
Lots of editors have problems with character encodings - also it can be difficult sometimes to tell what the encoding of a bit of text is, say if it was pasted in from somewhere.
+12  A: 

Notepad++ is highly recommended.

+1  A: 

Try BabelPad. Editing-wise, it's simple. Unicode-support-wise, it's awesome!

+3  A: 

EmEditor is written by a Japanese company for exactly this purpose. It is a fine text editor with good performance/simplicity but pretty much all the features expected of a capable editor; I use it as my default when on the Windows platform, as well as for editing Japanese web page templates. It deserves to be better-known IMO; it is at least as good as, say, TextPad, but with full Unicode support.

Unfortunately it is not free, however you can find a free version of the old EmEditor 6 at sites such as

+4  A: 

There is an issue with most Unicode-aware text editors: when you select a font, they stick to it. If the font does not include a glyph for a character, then the default substitution character (I believe U+FFFD, REPLACEMENT CHARACTER) is used.

In contrast, web browsers typically try to find a glyph for the characters they have to display among all the fonts provided by the system.

So, what you need, if you don't have the font "Arial Unicode MS" or similar (including Japanese glyphs), is an editor that tries to match glyphs with other fonts except the selected one.

Until someone provides a link for such an editor, I'll suggest a (somewhat extreme :) editor:

  • Install the latest stable python 2.x version for MS Windows (currently 2.6).
  • Include "idle" in the installation.
  • Start → Programs → Python 2,6 → Idle (Python Gui)

The "idle" editor is typically used to edit python code (and test it interactively in the Python shell). However, it can be used as a plain fully-Unicode-aware text editor, and when saving text including non-ASCII chars, it defaults to UTF-8 encoding.

Now, idle is based on Tkinter, which is an interface to tk, which is a gui library for tcl; tcl/tk, like web browsers, when asked to display a character for which no glyph is present in the widget font, it searches other fonts too.

However far-fetched this may seem, I really believe it would help; if no other solution helps you, give it a try.


Kate. and by extension, any other KDE program that uses Kate as an embedded KPart (KWrite, Quanta+, KDevelop). It handles lots of encodings, but i like to always use UTF-8. It also has a huge collection of syntax highlightings.


Notepad++ is the way to go for UTF-8

in other news, Notepad++ is working on version 5.1, which will also support Unicode

+1  A: 

EditPad Lite and Pro fully support Unicode as of version 6.

If you get question marks, you're using an encoding that does not support Japanese characters. In EditPad, you can change the text encoding (Unicode, legacy code pages) via Convert, Text Encoding. You can set the defaults per file type in Options, Configure File Types, Encoding.

If you see squares instead of Japanese characters, select a Japanse font or Unicode font. You can do this in EditPad via Options, Font.

To type Japanese, simply install a Japanese keyboard driver in the keyboard settings in the Windows Control Panel, if you haven't already.

EditPad Pro has preconfigured file types for PHP and HTML.

Jan Goyvaerts

Try SciTE It's just great ;)

+2  A: 

I've never had a problem with vim as long as I use a font that actually contains the characters I want. It needs to be a monospace font. :set enc=utf8 to get to utf8 mode. Then you can use :digraph command to get a display of available characters, and see how each is displayed.

To add a font, add it in Windows (Control Panel/Fonts/Add Font). If it's a monospace font, it will then show up in vin in /Edit/Font.

le dorfier

EditPad Pro ... is recommended for u

cheers ;)


Notepad++ will get my vote, its free and is actively developed.

Granville Barnett

For very basic UTF-8 multilingual text editing, I have had good luck with BabelPad ( it's free, simple and robust and displays almost everything with no fuss. When the editing needs are more severe, I resort a lot to EditPad Pro, or occasionally Notepad++. For non-Unicode editing on Windows, I'm a TextPad user--my staff and I have probably spent about 200,000 hours in TextPad, with only occasional forays into NotePad2, MadEdit, jEdit, XML Copy Editor, and EPCedit. The latter two handle UTF-8 XML files well. All of the editors mentioned above are free except TextPad and EditPad Pro. Thanks to the person who suggested Emeditor. I'll try it out. --PFSchaffner


Just to add another one: I just checked that Programmer's Notepad 2 has some UTF-8 setting too.

(vim and emacs do just fine as well)

Don Johe

I like jEdit for it's ability to ident wrapped lines. Really nice when editing XML files. A word of warning though: It's Java, so it's not light fast, like you would expect a text editor to be.

Text codecs are fully supported. It distinguishes between text files with and without the header identifying the file format (byte order mark), calling them UTF-8 and UTF-8Y. This is something that I'm missing in other text editors.

Jan Aagaard

Try EditPlus. It has specific support for HTML, syntax highlighting and can also work as a simple IDE for any compiler.


On the Mac: SubEthaEdit has excellent support for character encodings.


EmEditor fully supports UTF-8 and, since it was developed by a Japanese company, it of course supports anything you'd like to do with Japanese.


jedit X...will solve your problem....

Link to it's website..


Vim works fine for me as a UTF-8 text editor.

Firstly, you need a font that has the characters you are using. Choosing another text editor won't help you with this (unless it searches for other fonts for the correct characters when the font you are using doesn't have them). If you are using gVim, you can set the font like:

set guifont=Consolas

(This is not to say that Consolas is the font you want.) You probably want to put this in the .vimrc file so that it is always used.

Secondly, Vim needs to interpret the file as UTF-8, which it doesn't always automatically do. To make it do this, do:

set encoding=utf8

You can also see what encoding it is using with:

set encoding?
David Johnstone

EditPlus seems to be an better option for UTF-8 as I have used it.