I would like to fix up some error messages my site generates. Here is the problem:
class Brand < ActiveRecord::Base
validates_presence_of :foo
...
end
My goal is to make a message "Ticket description is required" instead of "Foo is required" or may not be blank, or whatever.
The reason this is so important is because lets say previously the field was ticket_summary. That was great and the server was coded to use that, but now due to crazy-insane business analysts it has been determined that ticket_summary is a poor name, and should be ticket_description. Now I don't necessarily want to have my db be driven by the user requirements for field names, especially since they can change frequently without functionality changes.
Is there a mechanism for providing this already?
To Clarify
:message => does not seem to be the correct solution, :message will give me "Foo [message]" as the error, I am looking to change the messages generated field name, not the actual message itself (though I will settle for having to change the whole thing).