So I know it's considered somewhat good practice to always include curly braces for if, for, etc even though they're optional if there is only one following statement, for the reason that it's easier to accidentally do something like:
if(something == true)
DoSomething();
DoSomethingElse();
when quickly editing code if you don't put the braces.
What about something like this though:
if(something == true)
{ DoSomething(); }
That way you still take up fewer lines (which IMO increases readability) but still make it unlikely to accidentally make the mistake from above?
I ask because I don't believe I've ever seen this style before for if or loops, but I do see it used for getter and setter in C# properties like:
public string Name
{get;set;}
Not asking what's best since that's too subjective, but rather just whether this would be considered acceptable style and if not, why not.