As stated in the framework design guidelines and the WWW in general, the current guideline is to name your constants like this
LastTemplateIndex
as opposed to
LAST_TEMPLATE_INDEX
With the PascalCasing approach, how do you differentiate between a Property and a Constant.
ErrorCodes.ServerDown
is fine. But what about private constants within your class ? I use quite a lot of them for naming magic numbers.. or for expected values in my unit tests and so on.
The ALL_CAPS style helps me know that it is a constant .
_testApp.SelectTemplate(LAST_TEMPLATE_INDEX);
*Disclosure: I have been using the SCREAMING_CAPS style for a while for constants + I find it more readable than squishedTogetherPascalCasedName. It actually STANDS_OUT in a block of text*