Has anybody managed to get the Android Emulator working behind a proxy which requires authentication?

I've tried setting the -http-proxy argument to

http://DOMAIN/USERNAME:[email protected]:PORT

but am having no success.

I've tried following the docs to no avail. I've also tried the -verbose-proxy setting but this no longer seems to exist.

Any pointers?


I've not used the Android Emulator but I have set the $http_proxy environment variable for perl and wget and a few cygwin tools on windows. That might work for you for android, but the slash in the domain name seems like a potential problem. I know I tried having my domain "GLOBAL" in there, but ended up taking it out and sticking with: http://$USER:[email protected]:80

One problem I run into a lot though is programs that cannot be told to use the proxy for DNS queries too. In cases where they don't I always get a host name not found. I'd like to find a local dns resolver that can use the proxy for all the programs that won't.

+2  A: 

I remember having the same problem - After searching on the web, I found this solution - From the command line,

1. > adb shell
2. # sqlite3 /data/data/com.google.android.providers.settings/databases/settings.db
3. sqlite> INSERT INTO system VALUES(99,’http_proxy', 'proxy:port');
4. sqlite>.exit

EDIT: With 0.9, sqlite3 is not shipped anymore. The correct way now is to use to use the -http-proxy flag with the emulator or set the http_proxy environment variable

in sdk 2.1, it should be: sqlite3 /data/data/com.android.providers.settings/databases/settings.db
+6  A: 

It seems like SDK 1.5 onwards, the -http-proxy flag also doesn't work. What did work for me is to boot the android image in the emulator and then once Android is running, go to Home > Menu > Settings > Wireless Controls > Mobile Networks > Access Point Names and then setup the http proxy settings for the default access point.

With the APN proxy settings in place, I can get the emulator's browser to surf the web. However, other stuff like Maps still doesn't work.


Hi, I am using android emulator 2.1. I was not able to access internet using emulator, since inside a proxy network. Could anyone please let me know the step by step procedure to set up an APN ? My proxy IP & port :


This is a question and you should post it as such instead of as an answer.
Jonas Elfström
BTW I'm also trying to figure out how to use a web proxy in Android 2.1 http://www.forceclose.com/questions/1745/is-it-possible-to-browse-by-proxy-in-android-2-x
Jonas Elfström
+1  A: 

Jay, though that would be the ideal place for this information, it has not been updated for 2.1. Below I will list the methods that currently do NOT work for the 2.1 emulator.

The http-post argument does not work for the 2.1 emulator. Setting a proxy in the APN list within the 2.1 emulator does not work. Inserting the proxy directly into the system table via sql-lite does not work with 2.1.

In fact, the ONLY way to get the browser to connect to the internet via the emulator that I've found in 2.1, is to NOT use a proxy at all. I really hope this gets fixed soon, for there are many people with this same problem.

+1  A: 

Apparently this problems runs only with Android 2.x and Windows. There is a opened bug here : http://code.google.com/p/android/issues/detail?id=5508&q=emulator%20proxy&colspec=ID%20Type%20Status%20Owner%20Summary%20Stars


Yes, I looked at it & I tried everything mentioned above. I'm running 2.1 emulator & trying to direct its requests through proxy, but no luck so far.


Actually its difficult to enter the proxy setting i tried all those methods but its of no use .


Here is a step by step guide on how to use proxy in Android Phones

Android Proxy

Android Proxy

I Managed to do it in the Adndroid 2.2 Emulator.

Go to "Settings" -> "Wireless & Networks" -> "Mobile Networks" -> "Access Point Names" -> "Telkila"

Over there set the proxy host name in the property "Proxy" and the Proxy port in the property "Port"

Sandeep Singh

antrix's solution worked for me.

go to Home > Menu > Settings > Wireless Controls > Mobile Networks > Access Point Names and then setup the http proxy settings for the default access point.