I have seen an advice somewhere here on SO to not name private/public
member variables, in a way that they differ only by the case of the very first character. For instance:
private string logFileName;
public string LogFileName
{
get
{
return logFilename
....
and: private System.Windows.Forms.MainMenu mainMenu;
and: DialogResult dialogResult = this.saveConfigFileDialog.ShowDialog();
and:
public Version Version
{
get;
set;
}
and:
private void CheckPollingType(PollingType pollingType)
{
So, did I hear wrong? Is there anything wrong with these naming conventions? If yes, then what are better ways of doing it? Links, references are a plus.
Thanks.