I have a variable that indicates the length of time the UI can be idle. I have elected to call this variable UITimer
. I want to pass the variable into my classes constructor and then store it off in a local field.
What is the proper way to do the casing of this? We use the common convention of a parameter not being capitalized. So should I do this:
uITimer
or this?
uiTimer
Also, we do an underscore and lowercase first letter for our fields.
Should that be declared like this:
private int _uITimer
or like this
private int _uiTimer?
I think _uiTimer is the way to go (the other option seems lame) but I am interested to see if I am missing something.
Best answer would be a link to a doc that says that acronyms should all keep the same case in C# naming (or something like it)