For my CMS application I'm writing a DLL that I will include into my projects. That DLL will include funtionality like retrieving all news for a specific project.
For instance, my database contains a table called News. By using the Entity Framework 4 I have a automatic generated class called News. I do not want my DLL methods return this object rather than a wrapper class, that only contains properties.
How should I name this wrapper class? For now I've always appended the word "Container", but over the time I do dislike this suffix. Meaning, I would now name this class NewsContainer.
Of course I could name this wrapper class also News. This would work because I'd have two classes in two seperate namespaces, but I'd rather not name two different classes the same. Is is ok, two name to different classes the same? I'm asking this, because News would actually the best name fit.
Edit: I do manually map the properties between my own wrapper class and the automatic generated entity framework class, if that is of any importance.