views:

11

answers:

1

Hi,

how should I name array that holds widths of columns? I would use:

int[] columnsWidths;

but I saw in many places names like:

columnWidths

or

colWidths

Of course "widths of columns" is only an example.

Moreover, I think there is also another case, when 2 words are not 2 separate words, but create some kind of name, e.g.

class TableView

How in this case variable's name should look like?

TableView[] tableViews;

or

TableView[] tablesViews;
A: 

Read Code Complete. But there is no right or wrong answer -- choose what suits you and your colleagues and be consistent.

High Performance Mark