I find it useful (in any language) to NOT chain method calls together in most cases. The cons to doing this are
1) If there is some sort of null exception, it is difficult to know where it occurs, especially if the code looks like
if (a.b.c.d.e || f.g.h.i.k) { ... }
then your NPE like exception could have happened in any of 10 places. Imagine if the variables are more than 1 letter long.
2) The code is less readable this way. The following is infinitely more readable.
var b = a.b,
c = b.c,
d = c.d,
e = d.e;
var conditionOne = e.isTrue()
you don't necessarily need to create a var for every level, but you could for levels that make sense.
3) Its easier to see what is going on in a debugger if the variables are separated out.
The bottom line is, with some extra typing your code is a lot more readable and a lot more maintainable.