tags:

views:

455

answers:

11

Rules:

You have to be the one who named it.

It has to have made it into production.

Mine: (the comment is the original comment I added)

    //WTF?? this should be rethough
    private static float CalculateFudge(bool isLeft, bool isRight, DesignedRoom r)
    {
       ..snip..
    }
A: 

Not mine, but

SecrityConuter

Sounds dirty huh?

Steve
-1 "You have to be the one who named it."
Rob Hruska
+4  A: 

ExportStuffAndShoveIt()

Export - Exports Data, Stuff - LZMA compresses it Shove - sends it to the remote computer (forcibly)

(:

Rob
Single responsibility principle.
Jason
+1  A: 

I did a Moo() function for a Cow class that did some weird things like sing my todo list... It was not a serious class!

Movaxes
I've done moos in CoW (Copy on Write) stuff, never as a function/API though.
roe
+4  A: 
public static String getBackdoorPassword()

As a part of public API, of course.

Yoni Roit
What did it actually return?
Oorang
A: 

Microsoft beat me on this one. Behold, IExpando!

Greg D
Not technically a method, I suppose, but really. So what? :)
Greg D
+2  A: 

I wrote a test method that attempted to do everything possible to crash the server and called it EatSh*tAndDie().

thaBadDawg
loooololollolololololololollolololololo
Sam152
Die You Gravy Sucking Pig Dog:http://www.codinghorror.com/blog/archives/001211.html
Oorang
A: 

I once wrote a class called UberDomain - for good reasons, I promise - but it was refactored into something else before it got to production.

Marcus Downing
+1  A: 

RequestMagic()

It copies all of the rows in a customer record into the request scope using wacky ORM tricks

Nick
Is that anything like a small metal switch labeled "More Magic"?
Oorang
+2  A: 
void yeyFunc();

I was so annoyed at an api someone wrote, I wrote a function to simplify his non-intuitive way of passing function pointers. Being able to use the function made me happy, so that's what I called it.

Andrei Krotkov
A: 

Pretty sure KillSelf() & KillUser() have made it into a few of mine. I also had a method to delete a log from a database called DropLog, but I thought better of it.

Oh and I wrote a denormalization tool that had a method called Recordify (pronounced Record-Eh-Fye). I was explaining what "denormalization" meant in laymen's terms and the guy thought that turn of phrase was funny and it got batted around so much it was left in.

Oorang
KillSelf should have been called Suicide. :p
Nixuz
And KillUser could be called "IfOnly"?
Oorang
+1  A: 

I named a pie chart routine iLikePie.

Nosredna
Haha I use that in tests all the time. Never in production though.
Oorang
I meant to change it to something acceptable, but I just couldn't.
Nosredna