I use camelCase
in my code and database field names, etc, but with fields that have Id
at the end, it always ends up being hard to read. For example, itemId
, teacherId
, unitId
, etc. In these cases I consider breaking convention and writing itemID, teacherID, or unitID
just for improved readability.
What do you do and what's a general, best practice of dealing with this issue?