What is the recomemded approach to naming base classes? Will it be prefixing the type name with a "Base" or "Abstract" or whould we just suffix it with "Base"!
consider the following:
type: ViewModel
e.g. MainViewModel, ReportViewModel
base class: BaseViewModel
or ViewModelBase
or AbstractViewModel
Also consider:
type: Product
e.g. VirtualProduct, ExpiringProduct
base class: BaseProduct
or ProductBase
or AbstractProduct
Which do you think is more standard?
class Entity : EntityBase
{
}
or
class Entity : BaseEntity
{
}