I have a method exposed as an OperationContract for my WCF service that i would like to rework. The previous programmer had written something like:
public ReportResultObject GetReport(string stringContainingParameters)
I would like to have a method that is something more like this:
public ReportResultObject GetReport(int[] someIds, bool includeAdditionalInformation)
Since WCF doesnt allow for overloaded methods without specifying the Name attribute in the OperationContract, and I dont want to break current clients, is there a naming convention for situations like this? Something like GetReportV2 or GetReportHeyUseMeInstead ?