This stackoverflow question has an interesting discussion on how to avoid giving enums and properties the same names so that you don't have code like this:
public SaveStatus SaveStatus { get; set; }
It seems the accepted answer suggested to use "State" for the enum and "Status" for the property:
public SaveStatus SaveState { get; set; }
But I think this is hard to read and not immediately clear what is what.
Since this enum naming problem is a constant issue, I am considering simply always suffixing my enums with "Enum" so I would have this:
public SaveStatusEnum SaveStatus { get; set; }
SaveStatus = SaveStatusEnum.Succeeded;
Does anyone do this? Happy with it? Solved this issue in another way?