views:

45

answers:

2

I have a list of media that i inspired and a list i was inspired by. In a table i named it inspirer, inspired. I am sure inspirer is not a word so thats one problem.

next is i have 2 functions, i want to pull a list of everyone i inspired and i was inspired by. inspired() and inspiredBy() can get confusing, so i need inspired as getInspirer(). But i am sure you guys can see the confusion. Should getInspirer() get a list of everyone i was the inspirer of or everyone who i was inspired by? Its just so confusing. What is a better table and method name.

+2  A: 

Use the word Inspiration instead of Inspirer. A person can be an inspiration.

Jared Updike
+2  A: 

I would create a table called Inspiration.

- InspirationID PK Int Identity
- InspirationDesc Text

I would then create another table for keeping track of the Inspiration to Inspiration relationship called InspirationSomething...

- InspirationParentID FK 
- InspirationChildID FK

You could then get your lists rather easily from there...

- GetInspirationParents()
- GetInspriationParents(id)
- GetInspirationChildren()
- GetInspirationChildren(id)
RSolberg
By the way, InspriationSomething should really be InspirationPairs or InspirationRelationships...
RSolberg