views:

1281

answers:

9

I need a good variable name for a boolean value that returns false when an object is the last in a list.

The only decent name I can come up with is 'inFront', but I don't think that is descriptive enough.

Another choose would be 'isNotLast'. This is not good practice though (Code Complete, page 269, Use positive boolean variable names).

I am aware that I could change the variable definition. So true is returned when an object is the last and call the variable 'isLast', however, it would make this task easier if I had the first explanation.

+3  A: 

isBeforeTheLastItem

isInFrontOfTheLastItem

isTowardsTheFrontOfTheList

Maybe too wordy but they may help give you ideas.

Bela
i think i am sold on 'isBeforeLast'...duh
Berek Bryan
Can't `isBeforeLast` be replaced with `!isLast`?
Joe D
+7  A: 

hasFollowingItems? or hasFollowingXXXXs where XXXX is whatever the item in your list is?

marklam
I was thinking along those lines. hasNext might work.
Patrick McElhaney
+5  A: 

Personally more than anything I would change the logic, or look at the business rules to see if they dictate any potential naming.

Since, the actual condition that toggles the boolean is actually the act of being "last". I would say that switching the logic, and naming it "IsLastItem" or similar would be a more preferred method.

Mitchel Sellers
+1. If I remember correctly, this is also the spirit of that section in Code Complete.
Austin Salonen
A: 

I would call the variable beforeLast.

John Topley
A: 

How about:

 hasSiblings
 or isFollowedBySiblings (or isFolloedByItems, or isFollowedByOtherItems etc.)
 or moreItems

Although I think that even though you shouldn't make a habit of braking 'the rules' sometimes the best way to accomplish something may be to make an exception of the rule (Code Complete guidelines), and in your case, name the variable isNotLast

Miky Dinescu
A sibling is something that has a parent in common with another sibling. There are no parents in a flat list.
John Topley
@John Topley: Yeah, I suppose you're right but you could argue that all items of the list are siblings and that their parent is the list itself.. I guess the isFollowedBySiblings could be renamed to something like isFollowedByItems, or byOtherItems or byMoreItems or something else. I still feel the isNotLast is the better name, unless he could change the meaning of the flag to the opposite and then call it: isLast (wow.. that was long :)
Miky Dinescu
+1  A: 

Haskell uses init to refer to all but the last element of a list (the inverse of tail, basically); would isInInit work, or is that too opaque?

Meredith L. Patterson
A: 

isPenultimateOrPrior

isBeforeEnd

Greg
A: 

Two issues to think about

  1. What is the scope of the variable (in other words: are you speaking about a local variable or a field?) ? A local variable has a narrower scope compared to a field. In particular, if the variable is used inside a relatively short method I would not care so much about its name. When the scope is large naming is more important.

  2. I think there's an inherent conflict in the way you treat this variable. On the one hand you say "false when an object is the last in a list", where on the other hand you also want to call it "inFront". An object that is (not) last in the list does not strike me as (not) inFront. This I would go with isLast.

Itay
+5  A: 

My vote would be to name it IsLast and change the functionality. If that isn't really an option, I'd leave the name as IsNotLast.

I agree with Code Complete (Use positive boolean variable names), I also believe that rules are made to be broken. The key is to break them only when you absoluately have to. In this case, none of the alternative names are as clear as the name that "breaks" the rule. So this is one of those times where breaking the rule can be okay.

Jeff Siver