The HTML spec shows the disabled
and checked
attributes for input
elements like this:
<INPUT disabled name="fred">
Whereas w3schools suggests doing it like this:
<input disabled="disabled" name="fred" />
Is there some reason to prefer one style over the other or is it just personal preference? I can't decide which I find more "readable," the simpler one or the one that's name/value pair like the other attributes.