I am following Google App Engine Guestbook sample to create a new servlet in src folder. When the create servlet dialog open, I found I can't choose or type "Web Project" and can't browse to select "source folder" either.

The eclipse is version 3.5, jdk I installed is 1.6.0_14-b08

I am working on Windows XP Pro with SP3.

Before I tried to create new servlet, I can compile and start the server, after visiting http://localhost:8080, sample app works fine.

Please advise. Thanks.

+1  A: 
Von, thanks for the reply, I did installed the GWT and AppEngine eclipse plugin. The project I created for that guestbook sample is a Web Application Project from Google folder. Also in the guestbook sample doc, it mentioned uncheck the GWT option. It supposed to be separated from GWT, right?

Same here. In the Create Servlet dialog (opened by right clicking on the package in my project, New > Other, then choose Web > Servlet), there is no choice in the "Project" drop down list: alt text

The "Browse" buttons for Source folder and Java package doesn't work either.

Installing GWT Web Project and adding such support in the existing project don't help. BTW, the project is already a Web Application Project created following the instructions stated here:

Instead, I have to create a Class and then manually set the superclass as javax.servlet.http.HttpServlet to add a servlet to the project.

Is it a bug in Google Plugin or Eclipse?