views:

80

answers:

4

I developed a static Console class that writes any traces, successes, and errors to a log file. It requires a file path String and a LoaderInfo instance to get started. At the moment, the function is named start(path, loaderInfo). I'm not really feeling the name "start", so I'm wondering if there's something more accurate. To me, start methods always have end/stop methods, but since this one doesn't, "start" doesn't seem appropriate.

+2  A: 

init (unless thats taken?)

Justin
I typically don't pass arguments through init methods. Is that weird?
destroytoday
kinda. I like Damian's 'attach' to a path approach. or just log(path, info); ?
Justin
+3  A: 

How about a touch of the Patrick Stewart?

makeItSo();

Damian Powell
Seriously though, I think Justin's suggestion makes sense. I don't feel like a Console should be started either. It might be 'attached' to a stream or set of streams though, I suppose.
Damian Powell
LOL - perhaps Engage is more appropriate?Like you said, Attach (params, ...) smells right to me.
Kieron
A: 

Console.logTo(path, loaderInfo) ?

mralex
A: 

I would go with startLogging(), then to be followed up by stopLogging().

Justen Holter