In some interfaces i wrote I'd like to name generic type parameter with more than one character to make the code more readable.
Something like....
Map<Key,Value>
Instead of this...
Map<K,V>
But when it comes to methods, the type-parameters look like java-classes which is also confusing.
public void put(Key key, Value value)
This seems like Key and Value are classes. I found or thought of some notations, but nothing like a convention from sun or a general best-practice.
Alternatives i guesed of or found...
Map<KEY,VALUE>
Map<TKey,TValue>