Sorry I dont know how to add a comment with the format, so I post another question with code here, as I am new to python, seems that there are many better ways to reorgnize the codes to make it better:
def min_qvalue(self):
s = 0
q = 1
for i in range(len(self.results)):
if self.results[i].score > s:
s = self.results[i].score
q = self.results[i].qvalue
return q
For the above code, should not be the best piece, any improvements possible? thanks :)