I'm looking for the official naming convention in Java regarding accessors.
I've seen that, for instance, the JPanel
class deprecated the size()
method in favor of getSize()
.
But in the ArrayList
class, the method is size()
.
So I'm wondering if accessors should be named getXXX()
or xXX()
?