I'm trying to edit a piece of code written by a development company, which uses the following construct a lot:
$dbcol = grabdata($strSqlB,'','','','','','',2);
Is there really not an easier way to do this? The code is completely unreadable.
I would have thought that the following would work, and work well for readability:
$vars = array("parameter1" => $strSqlB, "parameter7" => 2);
$dbcol = grabdata($vars);
is there anything that needs to be refactored in the function itself to make this work? Is there anything else clever we could do to make this less of a clusterfudge?