I don't really like this convention. I understand that it helps out with the case when you have an interface and an implementation that would have the same name, but I just find it ugly. I'd still follow it if it were the convention where I am working, of course. Consistency is the point of conventions, and consistency is a very good thing.
I like to have an interface describe what the interface does in as generic a way as possible, for example, Validator
. A specific implementation that validates a particular thing would be a ThingValidator
, and an implementation with some abstract functionality shared by Validator
s would be an AbstractValidator
. I would do this even if Thing
is the only... well... thing that I'm validating, and Validator
would be generic.
In cases where only one concrete class makes sense for an interface, I still try to describe something specific about that particular implementation rather than naming the interface differently to prevent a names collision. After all, I'm going to be typing the name of the interface more often than the name of the implementation.