How important is it for readability that code be in this form:
public void DoStuff()
{
var v = new Object();
v.PropertyID = "abc";
v.Type = "abc";
v.Style = "abc";
v.SetMode(Mode.Abc);
v.Draw();
}
vs.
public void DoStuff()
{
var v = new Object();
v.PropertyID = "abc";
v.Type = "abc";
v.Style = "abc";
v.SetMode(Mode.Abc);
v.Draw();
}
I tend to like the first style best, it makes things easy to read, how would you gently guide people towards the former and away from the latter? Or would you not?