I'm a bit newbieish when it comes to the deeper parts of OSX configuration and am having to put up with a fairly irritating niggle which while I can put up with it, I know under Windows I could have sorted in minutes.

Basically, I have an external disk with two volumes:

One is an HFS+ volume which I use for TimeMachine backups. The other, an NTFS volume that I use for general file copying etc on Mac and Windows boxes.

So what happens is that whenever I plug in the disk into my Mac USB, OSX goes off and mounts both volumes and shows an icon on the desktop for each. The thing is that to remove the disk you have to eject the volume and in this case do it for both volumes, which causes an annoying warning dialog to be shown every time.

What I'd prefer is some way to prevent the NTFS volume from auto-mounting altogether. I've done some hefty googling and here's a list of things I've tried so far:

  • I've tried going through options in Disk Utility
  • I've tried setting AutoMount to No in /etc/hostconfig but that is a bit too global for my liking.
  • I've also tried the suggested approach to putting settings in fstab but it appears the OSX (10.5) is ignoring these settings.

Any other suggestions would be welcomed. Just a little dissapointed that I can't just tick a box somewhere (or untick).

EDIT: Thanks heaps to hop for the answer it worked a treat. For the record it turns out that it wasn't OSX not picking up the settings I actually had "msdos" instead of "ntfs" in the fs type column. Cheers!

+1  A: 

This is not directly an answer, but

The thing is that to remove the disk you have to eject the volume and in this case do it for both volumes

I have a similar situation.

OSX remembers where you put your icons on the desktop - I've moved the icons for both of my removable drives to just above where the trash can lives.

Eject procedure becomes

  • Hit top-left of screen with mouse to show desktop
  • Drag small box around both removable drives
  • Drag 2cm onto trash so they both get ejected
  • Remove firewire cable
Orion Edwards
+2  A: 

The following entry in /etc/fstab will do what you want, even on 10.5 (Leopard):

LABEL=VolumeName  none    ntfs    noauto

If the file is not already there, just create it. Do not use /etc/fstab.hd! No reloading of diskarbitrationd needed.

If this still doesn't work for you, maybe you can find a hint in the syslog.