I use Netbeans mainly for PHP.

When Setbeans starts, it always indexes all the files of all the projects I have on my list. This can take over half an hour in my case, since I have some very large websites open.

It got better in 6.7, 10 minutes at most, but still a waste of time.

Still, I'd like to turn off the indexing completely.

Netbeans has so much options, I can't see the forest for the trees.

Can anybody tell me if this is possible with a setting? Or do I need to compile Netbeans myself with an option turned off?

I'm working on Windows Vista.


Mhhh I don't find exactly something like that but try this:

Go to Tools > Options > Editor and disable all the options in Code Completion and Hints

I suppose if you don't have Code Completion and Hints enabled Nebeans must disable indexing at start...

Also you can try closing all the projects (or some of them) when you exit.

Closing the projects at exit isn't a good idea. When you start Netbeans again, they won't be there, that is true. So they won't be indexed at the moment of startup. But the moment you need to work on them, you have to add them. And when you add them, they get indexed anyway. So closing them at exit is only useful if you know you're not going to work on that project any time soon.Also, I need code completion and secondly: no it does not influence it.
+2  A: 

well known problem, final solution not yet available, but maybe a work-a-round for you ....

see this plugin which stops automatic scans and adds a RefreshAll option to the Files menu. There's a risk to get your indexes out of sync, so use it with care. It worked for me.

Good luck MikeD

Getting a weird error message: The proxy server received an invalid response from an upstream server.The proxy server could not handle the request GET /ScanOnDemand.Reason: Error reading from remote server
I don't face that issue - having a basic Netbeans environment with Glassfish, JavaDB, Standard and Mobile edition, Nokia S40 simulator on XP. My default browser is Chrome.Cou may want to send a note to the developers - this code is still under development.
... and I "use system proxy settings" ... seems you run into a 502 error somewhere ... not necesarrily linked to a web server, could be any server (DB, ...) which disagrees with your proxy about the protocol usedcan you clarify if that happens at download time or while using the plugin ??
Okay, I got it and downloaded it. It's installed and it does add the "Refreshall" option, but Netbeans still scans my projects. Only difference is that I can stop the scanning manually.
sounds like a progress .... probably we can't expect more than that at this time :-)