As you may know, in VS 2008 ctrl+tab brings up a nifty navigator window with a thumbnail of each file. I love it, but there is one tiny thing that is annoying to me about this feature: the window stays around after releasing the ctrl key. When doing an alt-tab in windows, you can hit tab to get to the item you want (while still holding down the alt key), and then when you find what you want, lifting up on the alt key selects that item.

I wish VS 2008 would do the same. For me, when I lift off of ctrl, the window is still there. I have to hit enter to actually select the item. I find this annoying.

Does anyone know how to make VS 2008 dismiss the window on the release of the ctrl key? Thanks!

Edit: additional info

I'm not liking how this is turning out. ;-) I can't reproduce it on my coworker's machine. I do have VS 2008 SP1. I've tried removing uninstalling all VS addins, different keyboards, and resetting key mappings. It is still happening on my box. Any ideas of things to try?


Doesn't seem to happen to me. But I wasn't aware of that feature before, and I just tried it today. You might want to try installing Service Pack 1, as I also just installed that today, and the behaviour seems to have been fixed.


Maybe they changed it in SP1, but it works that way in mine. Holding down CTRL, tab cycles through the pages. When I let off of CTRL, it selects that page and disappears. I never tried it before SP1, so can't tell you if it's new behavior.


I can't replicate this behavior. When I let go of Control, the window switcher disappears. I looked through the settings and didn't find an option for this either. Stuck key maybe?

John Sheehan
+1  A: 

Strange. My VS2008SP1 install exhibits your desired behavior (in a web application project). I do not recall making any explicit changes.

Forgotten Semicolon

I can't reproduce either (non-SP1), but thanks for letting me know about that feature! Quite useful!


Also can't replicate it (I have VS2008 SP1)

It may be a problem at your end... have you tried fixing your installation?

Juan Manuel

Sounds to me like your keyboard has a stuck key. Try to find out if Control is sticking by running osk.exe (Windows built-in On-screen keyboard) which will show you what keys are being pushed.

John Sheehan
+6  A: 

You probably have the text-to-speech narrator enabled.

Just uncheck all checkboxes under "Text-To-Speech" narrator software.

--> To open Narrator using the keyboard, press CTRL+ESC, press R, type narrator, and then press Enter.

This one drove me crazy for several months until I found this posting.

Carl Russmann
Thanks for posting this, but I tried it and it didn't work. I started Narrator as described and unchecked all checkboxes. I also unchecked "Use Narrator" in the Control Panel. I still have to press Enter after Ctrl+Tab. What else could I try?
I got the same problem in Win7 now
Johan Danforth

I would uninstall and reinstall VS altogether.

Did you try Carl's suggestion

Juan Manuel
+1  A: 

I am also stuck with this problem (VS2005, Vista).

I found this blog entry saying there might be a registry entry, but not what it was.

By monitoring registry reads at startup, I found VS2005 checks:


Entering a dword value of 0 in the registry didn't help me though.

Sticky keys are off, navigator is not running, my control key is not stuck. I did recently enable speech recognition (although it's not running) - anyone else got this as a common factor?


I too am cursed with exactly the same misbehavior of the ctrl+tab/ctrl+F6 selection except my platform is Vista Service Pack 1 with Eclipse 3.4.2 and the SlickEdit Core plugin 3.4.0 . Yes I tried the narrator fix. Yes I wiped eclipse off the system and redownloaded CDT and SlickEdit core. No change.

I have an additional misbehavior data point. Those of you using a pure slickedit environment (no eclipse) may not be aware that when you install SlickEdit under Eclipse, it provides an alternate editor for C/C++ (and other) files. Using this editor you get access to all the cool slickedit stuff. When I use an Eclipse right-click handler in the editor to use the original Eclipse editor on several of my open tabs, then Eclipse's own 'ctrl+F6' handler works properly! Note that there is a different look-and-feel to the editor list popup that appears when starting from the Eclipse-provided editor than when starting from the SlickEdit provided editor.


I tried unchecking all the options in "narrator". And it works for me !! Thanks a lot...

+1  A: 

I found this behaviour when I was running VS2008 under windows 7 and had been using the magnifier app.

I suspect it would similarly occur under vista.

Basically I had zoomed all the way back out but not shut down the magnifier app. Once it was shut down, things returned to normal.

Rory Becker
+1  A: 

This bloody thing is haunting me as well. Visual Studio 2008 SP1 and Windows 7 64-bit. Setting the registry key mentioned in this thread won't help. Sara Ford brags that she knows the right key ( but she won't tell. I guess the marvelous tip is too large to fit on the margin of the page or something.

Also turning all the narrator options off or on doesn't help (but it does make me and my co-workers crazy.) As a bonus starting the narrator.exe (WIN-R narrator ENTER) starts up the windows magnifier (magnifier.exe) and it immediately zooms into molecule level without giving way to zoom back (ctrl +/-, win -/+, win-mouse wheel, esc doesn't work.) Have to kill it from task manager, which is bloody easy when each pixel is the size of a pick-up truck. Magnifier never starts up when you need it (supposed to start up with win-+), but it does occasionally go into mode where it starts up ON EACH BLOODY LOGIN, remote desktop or not. And zooms into atom scale with no way to get back. The later (week or so) it goes away. The control panel setting doesn't seem to help.

Also, I've had this sticky ctrl-tab issue at least twice to three times (right now I'm having it) and it has gone away after few weeks without clear reason why. I've just bit my teeth and gone on. But now I've had enough.

Microsoft: I won't blame you on adding accessability features for disabled people, but for god's sake don't in-your-face them at me all the fscking time. Fix the bloody thing, all I'll make sure you're seriously need accessability features the rest of your life.

Vieno Huttunen
I now just live with the problem, enjoyed your rant though.

Just in case anyone still needed a fix for this (I've encountered this behavior in VS2010) what you can do is:

  • Close VS
  • Enable sticky keys
  • Reopen VS
  • Disable sticky keys

This solved it for me.