I have this java code:
if(isNull(office) || isNull(pricelist)) {
log.warn("The document {0}-{1} is not valid.",codDoc,numDoc);
return null;
}
Do you think it is ok if I rewrite it as:
if(isNull(office) || isNull(pricelist))
return log.warn("The document {0}-{1} is not valid.",codDoc,numDoc);
That way
public void warn(String logLine, Object... args)
{...}
would become:
public Object warn(String logLine, Object... args)
{...;return null;}
Take into consideration that logging is mandatory in this system. Thanks for your comments.