Can someone point me to a guide for naming methods that return boolean or indicate a boolean state? I'm talking about things I've named like recordsExist(), issetVariable(), questionPrompted(), commentAsked().
Thinking this over, I think that two basic problems I'm looking at are 1: Has a user-interface event happened? and 2: do[es] data exist? Another case, whether or not an adjective is true, isAdj() or isNounAdj convention works -- isValid(), isSent(), isNull(), isEmailSent(), areRecordsUpdated(), etc.
I'm sure other people have thought more thoroughly about this problem, and come up with more robust solutions than I have. In what other classes of scenarios do we return boolean, and what naming conventions do we use for them?