Hello all,
I soon started a small C++ project and elaborated some naming convention rules for variables, according to scope.
I made class members _prefixed_with_underscore
and methods parameters suffixed_with_underscore_
. I soon got neurotic about inventing naming conventions for everything, like global variables (ok, those might be important), inline global functions, to try to improve code readability.
I've read this question and its answers that answered some of my doubts about naming convention, specially about methods parameters names. Maybe having a_rule_like_this_
for parameters names might not be a good idea.
So, my question is, what naming conventions do you use for different "entities" when programming, specially for parameter names? Thanks.