Introduction:
I'm working on API which provides access to Picasa, Flickr and some other image services.
I have a class WebAlbum (it provides access to nested photos, albums if allowed, and some meta information).
My API allows not only read albums but it also allows to create new albums. In general case in order to create new album API user should user factory method which creates album and then call method WebGallery#addAlbum (newAlbum)
.
But Flickr doesn't allow to create empty albums, it requires at least one predefined photo in any new album (to make nice album preview probably). In Flickr terms this first photo is called Primary Photo
. So in order to create album for Flickr user should use factory method, then add an image to the new album, and then call WebGallery#addAlbum (newAlbum)
.
Problem:
At the moment WebAlbum class has method
public interface WebAlbum {
...
public boolean requiresPrimaryPhoto ();
}
I can't leave this name because PrimaryPhoto is just a Flickr term. I can change it to
public interface WebAlbum {
...
//with spaces: requires one added photo to create new album
public boolean requiresOneAddedPhotoToCreateNewAlbum ();
}
Suggest me better (i.e. shorter) name which has the same meaning.