Don't know if it's really worth the time, but if you really want, you could try building something similar to google's cpplint, which does checking of their style guide.
I personally think that thorough reviews and people's commitment to follow certain conventions is a much better way to make sure your code is "indented properly" and variables named consistently. Maybe invest in making a document like google has done, describing the details of acceptable style, and have people in your company accept it and stick to it.
Why humans are better than a script? The answer is quite simple: people will have to deal with the code later, they should care about the stuff they are writing. A variable name like i
will be fine for a script, but not going to slip from my eyes, if it is a clientCount
, it should just be named appropriately, script which would be able to do that might take over the world rather soon. :)