views:

1959

answers:

7

From using a number of programming languages and libraries I have noticed various terms used for the total number of elements in a collection.

The most common seem to be length, count, and size.

eg.

array.length
vector.size()
collection.count

Is there any preferred term to be used? Does it depend on what type of collection it is? ie. mutable/immutable

Is there a preference for it being a property instead of a method?

+2  A: 

To me, this is a little like asking whether "foreach" is better than "for each". It just depends on the language/framework.

EBGreen
And, what does it matter? What changes? Are we all going to write angry emails to the Java folks for picking two and being inconsistent?
S.Lott
That is my point. Why wonder which is better. It is what it is.
EBGreen
+1  A: 

Hmm...I would not use size. Because this might be confused with size in bytes. Length - could make some sense for arrays, as long as they are supposed to use consequent bytes of memory. Though...length...in what? Count is clear. How many elements. I would use count.

About property/method, I would use property to mark it's fast, and method to mark it's slow.

And, the most important - I would stick to the standards of the languages/libraries you are using.

badbadboy
+3  A: 

Count I think is the most obvious term to use if you're looking for the number of items in a collection. That should even be obvious to new programmers who haven't become particularly attached to a given language yet.

And it should be a property as that's what it is: a description (aka property) of the collection. A method would imply that it has to do something to the collection to get the number of items and that just seems unintuitive.

Corin
+24  A: 

Length() tends to refer to contiguous elements - a string has a length for example.

Size() tends to refer to the size of the collection, often this can be different from the length in cases like vectors (or strings), there may be 10 characters in a string, but storage is reserved for 20.

Count() tends to refer to the number of elements in a looser collection.

I think the main point is down to human language and idioms, the size of a string doesn't seem very obvious, whilst the length of a set is equally confusing even though they might be used to refer to the same thing (number of elements) in a collection of data.

gbjbaanb
Exceedingly well put!
Cerebrus
So what's a "looser collection"? I'm not seeing the difference between size and count here.
Ben Alpert
@ben: size = available slots, count = actual elements. size == count when the collection is full.
SnOrfus
@SnOrfus, that's still true, but I meant for collections that didn't have any meaningful contiguous elements, eg a map or a dictionary. You wouldn't say that a set had a length of 10 elements, there'd be a count of 10 elements in that.
gbjbaanb
+1  A: 

Adding to @gbjbaanb's answer...

If "property" implies public access to the value, I would say that "method" is preferred simply to provide encapsulation and to hide the implementation.

You might change you mind about how to count elements or how you maintain that count. If it is a property, you're stuck - if it is acessed via a method, you can change the underlying implementation without impacting users of the collection.

Ken Gentle
Why are you "stuck" if it is exposed as a property? Properties have an underlying implementation that can change just as easily without breaking the interface. In fact, most languages implement properties as compiler generated get/set methods anyway...you just can't call them directly.
Scott Dorman
Which "most languages" are you referring to? C, C++, Java (just to name a few) don't do this. Ruby and Groovy I know do. Please note how I started the answer, too: "If 'property' implies ..." Why stuck? If the interface to the class changes, clients have to change (generally speaking)
Ken Gentle
+1  A: 

The terms are somewhat interchangeably, though in some situations I would prefer one over another. Usually you can get the best usage if you think about "How would you describe the length/size/count of this element verbally to another person?".

length() implies that the element has a length. A string has a length. You say "a string is 20 characters long", right? So it has a length.

size() implies that the element has a size. E.g. a file has a size. You say "this file has a size of 2 MB", right? So it has a size.

That said, a string can also have a size, but I'd expect something else here. E.g. a UTF-16 string may have a length of 100 characters, but as every character is composed out of two byte, I'd expect size to be 200.

count() is very unusual. Objective-C uses count for the number of elements in an array. One might argue if an array has a length (as in Java), has a size (as in most other languages) or has a count. However, size might again be the size in byte (if the array items are 32 bit int, each item is 4 byte) and length... I wouldn't say "an array is 20 elements long", that sounds rather odd to me. I'd say "an array has 20 elements". I'm not sure if count expresses that very well, but I think count is here a short form for "elementCount()" and that again makes much more sense for an array than length() or size().

If you create own objects/elements in a programming language, it's best to use whatever other similar elements use, since programmers are used to accessing the desired property using that term.

Mecki
+1  A: 

FWIW (and that's vanishingly close to nothing), I prefer 'Count' because it seems to indicate that it's going to return the number of elements/items in the collection pretty unambigously.

When faced with the terms 'Length' or 'Size' I'm often left wondering for a moment (or even being forced to re-read documentation) whether the damn thing is going to tell me how many elements are in the colection or how many bytes the collection is consuming. This is particularly true for collections that are intended to be contingous like arrays or strings.

But no one who was responsible for the naming conventions used by the Java, BCL/.Net, or C/C++ standard frameworks/libraries bothered to ask me, so you're all stuck with whatever they came up with.

If only I were much smarter than I am and was named Bjarne, all of you might be spared the misery...

Of course, back in the real world, you should try to stick with whatever naming convention is used by the language/platform you're using (eg., size() in C++). Not that this seems to help you with your Array.Length dilemma.

Michael Burr