Do you have a naming convention for APIs or Classes that are being phased in to replace an older version that performed the same function / filled the same role?
E.g. Windows does this by adding "Ex" to the end of the function:
ShellExecute // old
ShellExecuteEx // new
What do you prefer, and what are you reasonings?
- Appending
2
,V2
,New
,NowInStereo
? - Doing a one-time rename of the old API from
Something
toSomethingOld
and usingSomething
for the new stuff? This option worries me when it comes to version control, but it also seems the least likely to be burdened with aV3
orReallyNew
problem in the future. - Making up a completely different name that may describe the function less accurately, but at least is different.