Unfortunately I have to use Windows Server 2003 on my 32 bit workstation due to memory constraints of Windows XP.

In Windows XP, when you connect via Remote Desktop the current session I am logged in is instantly shared on the Remote Desktop. I can see all the applications I have opened on my workstation and can continue to work on my open applications.

On Windows 2003 Server however, each Remote Desktop connection gets a new session. With no applications opened. So I have to use the Task Manager and connect to my existing session manually to see the opened applications.

Can this be changed so that Windows 2003 Servers acts exactly as Windows XP? I do not need to allow multiple users to connect to the box simultaneously. I would even like to prevent that, since it is used as a workstation and do not want to allow other domain users to start applications on my workstation.

+1  A: 

You can run MSTSC /admin or MSTSC /console depending on what version you have installed which will then connect to the console sessions

+2  A: 

The secret is to start Windows Terminal server client with the /console command so:

mstsc.exe /console

This will connect you to the existing cosole session rather than connecting you to a new session.

XP does this by default as it only supports a single (console) session. Windows Server support multiple sessions (depending on version and licensing) hence you need to specify /console when you want to connect to the existing console session.

David Linker
+2  A: 

Logon to any session on Windows 2003 server. Goto Administrative tools-->Terminal services configuration-->Server Settings-->Restrict each user to one session(check this box)

login again using RDP & you are good to go.


mstsc.exe /admin