Strings always copy in Objective-C, so the second option is most likely creating another string, and then pointing to it. In that way, I think you're right.
To play devil's advocate, I would assume that the compiler optimizes option B to do something like option A anyway. Personally, I would always do option B because it's more readable as far as the end operation you want to accomplish.
UPDATE: I didn't find a way to accomplish your goal differently, but you may be interested in this tidbit (from Apple UITextField Docs):
clearButtonMode
Controls when the standard clear
button appears in the text field.
@property(nonatomic)
UITextFieldViewMode clearButtonMode
Discussion
The standard clear button is displayed
at the right side of the text field as
a way for the user to remove text
quickly. This button appears
automatically based on the value set
for this property.
The default value for this property is
UITextFieldViewModeNever.
I think this would allow you to setup functionality for the user to clear the text field.