for (;;) {
//Something to be done repeatedly
}
I have seen this sort of thing used a lot, but I think it is rather strange...
Wouldn't it be much clearer to say while (TRUE)
, or something along those lines?
I'm guessing that (as is the reason for many-a-programmer to resort to cryptic code) this is a tiny margin faster?
Why, and is it REALLY worth it? If so, why not just define it this way:
#DEFINE while(TRUE) for(;;)
EDIT: I'm assuming TRUE to be defined to 1 and FALSE to 0.
Thanks for your input everyone.